Payment IVR - Unable to get into Secure Mode

Incident Report for SecureCo

Resolved

This incident has been resolved now
Posted Aug 04, 2025 - 10:40 AEST

Investigating

We are currently investigating an issue with completing payments using Payment IVR
Posted Aug 04, 2025 - 10:02 AEST
This incident affected: Payments (Payment IVR).