ServiceDesk Portal Logon Issue

Incident Report for SecureCo

Resolved

The public service desk web portal is now available.
Posted May 05, 2025 - 17:15 AEST

Identified

We are experiencing a logon issue with our public service desk portal. We are still receiving support emails and phone calls, though you may not be able to view current and past cases via the web portal
Posted May 05, 2025 - 09:24 AEST
This incident affected: Support Services.